GAP package NQ

Author: Werner Nickel
Needs: GAP, version 4.3 or more recent, GNU MP, GAP package polycyclic.
Operating systems: UNIX
Current version: 2.2
Status: accepted
Contact: nickel at
Download: Several formats available


This package provides an interface to the ANU Nilpotent Quotient Program for the computation of nilpotent factor groups of finitely presented groups. It requires the presence of the GAP package polycyclic.

This package provides:


Download and unpack one of the archives given below in the pkg subdirectory of your GAP installation.

Unpacking generates a subdirectory nq-X.Y where X.Y is the version number. Move nq-X.Y to the directory nq.

Follow the instructions in the chapter `Installing the package' of the manual. The manual is available below or in the subdirectory nq/doc.

To tell GAP about this package add a single line to the file 'ALLPKG' in the pkg directory containing just the word nq.

Online Documentation

The manual of the package is available in several formats. If the package has been installed properly, all of these documents are also accessible through the GAP online help.

NQ manuals

Package Archive for Download

The NQ package is availabe in the following formats:

The PackageInfo.g file is available as plain text file.

nickel at